MPLS lab time!

I started building the lab for the MPLS, this as i wrote before can be hard as there are no real books to say, “this is what you need, here is the layout ectc” I spent most of this week planning the lab that i would be doing every night. Trying to cover all the bases and understand why/what and how is going on.

Here is the lab lay out as it stands now after a weekend of labs.

Below is the RC from PE-1

ip vrf CustA
rd 1:10
route-target export 1:10
route-target import 1:10
!
ip audit po max-events 100
!
interface Loopback0
description PE1_LOOP_ZERO
ip address 172.16.111.17 255.255.255.255
!
interface FastEthernet0/0
description TO_P1
ip address 172.16.222.149 255.255.255.0
duplex auto
speed auto
mpls label protocol ldp
tag-switching ip
!
interface Serial0/0
description TO_CE1
ip vrf forwarding CustA
ip address 150.1.21.16 255.255.255.0
mpls label protocol ldp
tag-switching ip
!
interface Serial0/1
no ip address
shutdown
!
router eigrp 1
network 150.1.0.0
network 172.16.0.0
no auto-summary
!
address-family ipv4 vrf CustA
redistribute bgp 65001 metric 1000 100 255 1 1500
network 150.1.0.0 0.0.0.0
no auto-summary
autonomous-system 10
exit-address-family
!
router bgp 65001
no synchronization
bgp log-neighbor-changes
neighbor 172.16.2.33 remote-as 65001
neighbor 172.16.2.33 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 172.16.2.33 activate
neighbor 172.16.2.33 next-hop-self
neighbor 172.16.2.33 send-community both
exit-address-family
!
address-family ipv4 vrf CustA
redistribute eigrp 10 metric 1
no auto-summary
no synchronization
exit-address-family

I have not had as much lab time in the last week as i had hoped for, work has busy as ever. From cabling in the data centre to upgrading WLC’s in the dead of the night, it never stops.

BE.

Advertisements

~ by bigevil on September 13, 2010.

 
%d bloggers like this: